Announcement

Collapse
No announcement yet.

Issues with Pico Boo controllers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • eanderso13
    started a topic Issues with Pico Boo controllers

    Issues with Pico Boo controllers

    Has anyone else had issues with Pico Boo controllers having random freakouts? I have one, in particular, that is perplexing me. It is a PicoBoo Max that I programmed with the Director software. It runs our elevator, and I'd say 95% of the time it works fine. But lately, at least once or twice per night, the sound it plays while triggered will cut off, while the rest of the programmed routine runs. When the program is done, it goes back to Ambient mode and the ambient sound plays. So it does not seem to be that speaker wires are coming loose. I had the actor operating it tell me the other day that the whole elevator routine just stopped in the middle Saturday night. He unplugged the controller and plugged it back in and it worked for the rest of the night.

    Has anyone else experienced strange issues with these things? Do I maybe have a bad unit or are these things just not as robust as I am hoping they would be?

  • sean
    replied
    Shoot the guys a Fright Props an email. They'll get back to you right away. Anytime Ive had an issue, which is rare, they had done a tremendous job taking care of it

    Leave a comment:


  • N2SPOOKINU
    replied
    We have 16 of them in service at our attraction and every one of them work flawlessly. Are you running any 12v controls off of it? if so that might be whats throwing off the system if it is needing more power than the power supply provided can supply. I had that issue on 1 of ours but a quick change to a 5 amp power supply took care of the problem.

    Leave a comment:

Working...
X